PHPは7.0~7.4に対応

CS-Cartモール版はPHPで記述されたソフトウェアであり、PHPが動作するサーバー環境が必要となります。
現時点ではPHP7.0、7.1、7.2、7.3、7.4に対応しています。


データベースはMySQL4.1以上が必要

CS-Cartモール版では商品や顧客など、ほとんど全ての情報をMySQLデータベースに格納します。
現時点ではMySQL4.1以上が必要となります。


動作環境詳細

OS

  • Linux / FreeBSD / RedHat などのUNIX系OS
  • mod_security の無効化
  • .htaccess ファイルにおいて DirectoryIndex、Deny、Allow、Options、Order、AddHandler、RewriteEngine、RewriteBase、RewriteCond、RewriteRule を利用可能にする

PHP

  • PHP version 7.0、7.1、7.2、7.3、7.4
  • safe_mode の無効化
  • cURL の有効化
  • ImageMagick 7以降を推奨(GDライブラリでも可)
  • mbstring の有効化(encoding: UTF-8)
  • ftp_connect の有効化
  • file_uploads の有効化
  • fileinfo の有効化
  • Phar 拡張モジュール の有効化
  • ZipArchive 拡張モジュール の有効化

MySQL

  • MySQL version 4.1以上

ユーザー閲覧用Webブラウザ

  • Microsoft Edge の最新バージョン
  • Mozilla Firefox の最新バージョン
  • Apple Safari の最新バージョン
  • Google Chrome の最新バージョン

フィードバック

お役に立ちましたか?

はい いいえ
お役に立ちましたか
理由をお聞かせください
フィードバックありがとうございました

このトピックへフィードバック

送信